`
huobengluantiao8
  • 浏览: 1029249 次
文章分类
社区版块
存档分类
最新评论

poj-3349 Snowflake Snow Snowflakes

 
阅读更多
Snowflake Snow Snowflakes
Time Limit:4000MS Memory Limit:65536K
Total Submissions:20831 Accepted:5445

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integern, 0 <n≤ 100000, the number of snowflakes to follow. This will be followed bynlines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.



#include<iostream>
#include<vector>
using namespace std;
const int N=9997;
int i,j,k,snownum;
struct set
{
	int num[6],sum;
};
vector<set> hash[N];
bool contrast(set a,set b)
{
	for(int i=0;i<6;i++)
	{
		if(a.num[0]==b.num[i%6] && a.num[1]==b.num[(i+1)%6] && a.num[2]==b.num[(i+2)%6] && a.num[3]==b.num[(i+3)%6] && a.num[4]==b.num[(i+4)%6] && a.num[5]==b.num[(i+5)%6])
			return true;
		if(a.num[5]==b.num[i%6] && a.num[4]==b.num[(i+1)%6] && a.num[3]==b.num[(i+2)%6] && a.num[2]==b.num[(i+3)%6] && a.num[1]==b.num[(i+4)%6] && a.num[0]==b.num[(i+5)%6])
			return true;
	}
	return false;
}
bool search()
{
	for(i=0;i<N;i++)
	{
		for(j=0;j<hash[i].size();j++)
			for(k=j+1;k<hash[i].size();k++)
			{
				if(hash[i][j].sum==hash[i][k].sum  && contrast(hash[i][j],hash[i][k]))
					return true;
			}
	}
	return false;
}
int main()
{
	set temp;
	scanf("%d",&snownum);
	for(i=1;i<=snownum;i++)
	{
		temp.sum=0;
		for(j=0;j<6;j++)
		{
			scanf("%d",&temp.num[j]);
			temp.sum+=temp.num[j];
		}
		hash[temp.sum%N].push_back(temp);
	}
	puts(search()?"Twin snowflakes found.":"No two snowflakes are alike.");
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics