`
huobengluantiao8
  • 浏览: 1028780 次
文章分类
社区版块
存档分类
最新评论

poj-3258 River Hopscotch

 
阅读更多
River Hopscotch
Time Limit:2000MS Memory Limit:65536K
Total Submissions:3659 Accepted:1587

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end,Lunits away from the start (1 ≤L≤ 1,000,000,000). Along the river between the starting and ending rocks,N(0 ≤N≤ 50,000) more rocks appear, each at an integral distanceDifrom the start (0 <Di<L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up toMrocks (0 ≤MN).

FJ wants to know exactly how much he can increase the shortest distance*before*he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofMrocks.

Input

Line 1: Three space-separated integers:L,N, andM
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removingMrocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

有一条河长L,中间N块石头,最多去掉M块,求任意两个石头间最小距离的最大值;百度后才知道,这也个能用二分。。。






#include<iostream>
#include<algorithm>
using namespace std;
int l,n,m,i,j,ans,num[50010];
bool search(int a)
{
	int sum=0,temp=0;
	for(i=1;i<=n+1;i++)
	{
		if(num[i]-num[temp]<a) 
		{
			sum++;//两点间距离大于a,去掉一个点
			if(sum>m)
				return false; //去掉的点大于m,返回 
		}
		else
			temp=i;
	}
	return true;
}
int main()
{
	int max,min,mid;
	scanf("%d%d%d",&l,&n,&m);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&num[i]);
	}
	num[0]=0;
	num[n+1]=l;
	sort(num,num+n+1);
	max=l;
	min=0;
	while(max-min>=0)
	{
		mid=(max-min)/2+min;
		if(search(mid))
		{
			ans=mid; //解释下为什么在这记录答案:(max+min)/2  可能使得结果比答案少一(例如max=5,min=0,答案为3),去掉这句就不对了。。。 (解释的不好。。)
			min=mid+1;//返回为真,即mid偏小,可以增大 
		}
		else
		{
			max=mid-1;
		}
	}
	printf("%d\n",ans);
	return 0;
}





分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics