`
huobengluantiao8
  • 浏览: 1026873 次
文章分类
社区版块
存档分类
最新评论

poj-1905 Expanding Rods

 
阅读更多

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000


一根木棒根据温度变化,长短随着变化L'=(1+n*C)*L。 给出原长,温度变化和变化的系数C,求偏离原来的水平线多少。
直接推出偏离量不好求,通过几何找出r为中间变量,然后列出等式。



#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	double LL,c,degrees;
	while(~scanf("%lf%lf%lf",&LL,°rees,&c)) 
	{
		if(LL==-1 && c==-1 && degrees==-1)
			break;
		if(LL==0 || c==0 || degrees==0)//有一个为0得数为0; 
		{
			printf("0.000\n");
			continue;
		}
		double l=(1+c*degrees)*LL;//l为伸长后的量; 
		double max=acos(0.0);//选90°为最大度数 
		double min=0.0,mid=0.0;
		while(max-min>1e-12)
		{
			mid=(max+min)/2;
			LL/(2*sin(mid))<l/(2*mid)?min=mid:max=mid;//由2*r*mid=l以及2*r*sin(mid)=LL 得; 
		}
		printf("%.3lf\n",LL/(2*sin(mid))*(1-cos(mid)));//几何求解 
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics